Commercial back to COMMERCIALResidential back to RESIDENTIALCall support: 512-832-6939 ext. 415
Troubleshooting
FAQs
Fixed

Possible Cause
Damaged during install or shipping.

Solution
Please take pictures of the carton the frame arrived in and imperfections to the velvet.

Possible Cause
Wrinkles in newly installed material will eventually flatten out.

Solution
Please give the material time to heal. You can place the screen in a warm room to help the material relax. If the material does not flatten out, please contact Customer Support.

Possible Cause
The attachment hardware in the frame is not evenly spaced.

Solution
For screens with snaps, make sure the snaps are evenly spaced in the channel of the frame. For screens with bungees, make sure the post are evenly spaced in the channel of the frame. All bungees should be at ninety degree angles.

Possible Cause
The Maestro White material is bunched up on the tension rod.

Solution
Redistribute the material on the tension rod. Start at the point where the wrinkles are located.

Screen Innovations Support